Dotclear

Ticket #299 (closed defect: fixed)

Opened 13 years ago

Last modified 13 years ago

tpl:GalleryInclude : fichiers du thème par défaut non repris en cas d'absence

Reported by: bruno Owned by: bruno
Priority: normal Component: plugin:gallery
Severity: normal Keywords:
Cc:

Description

cf.  http://forum.dotclear.net/viewtopic.php?id=40529 :

Identification du problème :

  • Une galerie avec le thème "simple" (celui situé dans le répertoire gallery/default-templates/gal_simple) fonctionne parfaitement et chaque clic sur une vignette de la galerie renvoie sur le billet-image avec l'extrait, le texte et les commentaires
  • Les galeries auxquelles on a donné d'autres thèmes (rotator, jwplayer, flashgallery, tiltviewer) ne renvoient pas sur le billet-image qui s'affiche vide de la photo, de l'extrait et du texte : seuls les commentaires sont affichés !

Diagnostic :

En fait, il semble que, pour des raisons que ma modeste connaissance de dotclear ne me permettent pas d'expliquer, le module image.html qui affiche le billet-image (si j'ai bien compris) n'appelle pas le module image_item.html qui, lui, affiche la partie photo, extrait et texte du billet-image, quand ce module n'est pas situé dans le répertoire du thème actif. Il n'est donc appelé que quand le thème actif pour une galerie est "simple".

Il semble que ce soit un problème lié à l'utilisation d'un répertoire par défaut puisque ce module est effectivement commun à tous les thèmes : un bug doit empêcher la recherche de ce répertoire par défaut (???)

Change History

comment:1 Changed 13 years ago by bruno

  • Status changed from new to assigned

comment:2 Changed 13 years ago by bruno

  • Status changed from assigned to closed
  • Resolution set to fixed

(In [1756]) Fixed default inclusion in {{tpl:GalleryInclude}}, closes #299

comment:3 Changed 13 years ago by bruno

(In [1760]) Merged [1756] onto 0.3 branch, see #299

Note: See TracTickets for help on using tickets.

Sites map